The Compatibility Thread

Home page Forums Dragon Age: Origins Fixpack Forum The Compatibility Thread

Tagged: 

This topic contains 48 replies, has 7 voices, and was last updated by Qwinn Qwinn 3 weeks, 4 days ago.

Viewing 15 posts - 1 through 15 (of 49 total)
  • Author
    Posts
  • #142
    Qwinn
    Qwinn
    Keymaster

    Please post any findings regarding compatibility with other mods here. If it’s compatible, if it’s not compatible, if it’s mostly compatible but some of my fixes seem to not work, I’d like to know about it all. This will help me keep the compatibility list updated and accurate, saving everyone time and effort in getting a good clean installation.

    #288
    Mckatsims
    mckatsims
    Participant

    Seem to be compatible with 3.2: Lock Bash and No Helmet Hack. Both at Nexusmods. It’s early game, however, so if this changes I’ll update my post.

    #299
    Qwinn
    Qwinn
    Keymaster

    Good to know, thanks mckatsims! And yeah, let me know what you had working when you finish, some incompatibilities might not show up until later.

    #319
    Mckatsims
    mckatsims
    Participant

    I’m using Skip the Fade (because I hate the Fade part of the Broken Circle quest) and it seems to be working fine.

    That being said, my game usually crashes partway through the Sloth Demon boss battle. If I recall correctly, this seems to have always been an issue (even with the vanilla game), so this doesn’t seem to be an incompatibility issue with your fixpack.

    #360
    Mckatsims
    mckatsims
    Participant

    Okay, the No Helmet Hack mod doesn’t play well with your fixpack whenever I’m in Denerim. It creates a lot of texture glitches on everything. Uninstalling the hack completely fixes the issue – though restarting the game becomes problematic, as I’ve saved in the Denerim Market and the game crashes when trying to force start. Weirdly, this ONLY happens in Denerim.

    #361
    Qwinn
    Qwinn
    Keymaster

    Crashes when loading saves in the Denerim market are a vanilla issue, though it can crash and on the next attempt load fine, its intermittent. Lowering graphics settings can help get you through it.

    I don’t see how my fixpack could be causing that texture glitch issue though. Could you post the url of the specific mod youre using? I’ll give it a test. Theres lots of no helmet hacks, pretty sure even Dragon Age Rules Fixpack has one.

    • This reply was modified 4 months ago by Qwinn Qwinn.
    #366
    Firepanda
    firepanda
    Participant

    Hey Qwinn, sorry I never got back to you. Just started a new job.

    I tried installing Alley of Murders like you said, and it worked! Very sorry for all the trouble — I was indeed using damodder, which seems to install dazips like overrides. That probably also explains why I couldn’t get the character respec mod to work.

    #367
    Firepanda
    firepanda
    Participant

    The mod mckatsims is referring to is probably http://www.nexusmods.com/dragonage/mods/202

    It’s definitely the most robust and popular no-helmet mod, but the inner workings are well beyond me. I think it moves helms into a dummy ‘cloak’ slot. Don’t know why it would cause texture issues.

    #368
    Mckatsims
    mckatsims
    Participant

    Firepanda’s right, that is the mod I use to remove helmets. No idea why I have these texture issues with it installed, since from the description, it doesn’t appear to touch textures. The mod works well everywhere except Denerim, so I wonder if lowering my graphics settings would fix the issue. Aside from the texture glitching, Denerim works like a dream – no lag and stuttering at all!

    #482
    Qwinn
    Qwinn
    Keymaster

    Okay, I installed the main 1.6 version of the No Helmet Hack, but couldn’t duplicate the texture issue. The Market district seems fine to me texture wise. Does that mod use Event Manager? If it does, a known issue is that an excessive number of those kind of mods can cause unpredictable issues because there’s a hard limit on the number of script calls/events that the engine can handle (this is what I attempted to fix for the Siege of Redcliffe in Hotfixes v3.23 and v3.24), and if an area is already doing a lot of heavy script calling, those mods can put it over that limit. The Market District area script *is* very script heavy to begin with, which may be what you’re experiencing.

    Just running my fixpack and that alone, though, doesn’t seem to cause any problem for me even at max graphic settings. BTW, did you try toggling vertical sync on or off to see if that changes anything?

    #483
    Qwinn
    Qwinn
    Keymaster

    Responding to a Nexus post here:

    “Autoloot (latest version on bioware nit here. The one from Rules fixpack is less buggy)
    Party command unlock
    Advanced Tactics (Best overhaul, many bugfixes to combat)
    Extra Dogslot
    FTG Codex and Quickbar
    No helmet hack
    Fade Qunari – 4003
    Dead Templars – 4003
    Jowans Intention (Bioware Website)
    No Automatic Deactivation – 355
    Unlimited Stacks – 648
    Visible Commands – 1110
    Enemy Pulling Fix – 2074”

    Jowan’s Intentions is completely redundant. Added that to the upcoming v3.3 Readme.
    Extra Dog Slot is already listed as compatible.
    Fade Qunari and Dead Templars are tweaks, IMO. Should be compatible.

    The rest are combat/game mechanics mods that should be compatible, with the caveat that an excessive number of Event Manager Mods can break a game, a problem my mod has nothing to do with. In fact, any version of my mod after the v3.24 hotfix should be *less* likely to break in the Siege of Redcliffe than the vanilla game with those same mods installed, as that’s the most likely game event to break first due to that problem.

    #484
    Qwinn
    Qwinn
    Keymaster

    Also copying a long reply I gave on the Nexus forums to here:

    “Off the top of my head, Bye Oghren and Give Robbed Elves Money patch are redundant (I may not have done everything the same way Bye Oghren did – for example, at least as of this version, if you refuse to let Oghren come with you after the King is crowned, you DON’T get another chance to recruit him – but otherwise pretty much all the same content should be restored.)

    Valor the Warden – tweak, IMO.

    Additional Adjustments: A lot, but not everything, is redundant. I restored all the lore-related codex entries that were broken, like Luthias the Dwarfson and the 4 Sarel entries, but I don’t make the one that only mages can get available to everyone, for example. I do fix the Wynne stuff listed in the readme, and more, though I don’t give as much approval for doing her quest. The main missing thing is that I don’t restore the codex entries in the Control section of the Codex, primarily because A) they seemed unimportant, as they are not lore related, and B) adding them in would have required changes to core game files that would’ve created a lot of compatibility issues, more than I felt it was worth.

    Bergen’s Honor Fix: Appears to be morph/texture AND DLC related – won’t be doing it, but is fully compatible.

    The Unobtainables – no, I meant this one: http://www.nexusmods.com/dragonage/mods/1262/? I restored everything in that one except the two greatswords in the Korcari Wilds, since I think they were removed deliberately (there’s already a magic greatsword there – Chasind Flatblade, I think it’s called – and hardly any other kind of magic weapon. Unbalancing to add 2 more IMO). As for the mod you mentioned, I restore the second shopkeeper in Haven if you side with the Cult so the two related items are restored. I also restore the Gateway Amulet, the North Ward, and the Botanist’s Map of Thedas, but not the rest (which are all just gifts, I believe).

    Connor Epilogue Fix: He is no longer an elf in my mod, though I did not do anything beyond that as that’s the only part I considered a true fix. If you want him cleaned up, clothes changed, etc., the mod should be compatible (it will override my changes by default).

    Alistairs Oath: Not an illogical premise, but not going to go as far as to call it a bug. It should be compatible – I don’t change any of the follower’s creature files.

    Joining Ritual Fix: Appears to be an Awakening fix. I’m not doing those at this time, should be fully compatible.

    Non Circle Origin Mage Dialogue Fixes: No idea why the word “Fixes” is in the title of this one, appears to be 100% tweak. Probably not compatible either, though I didn’t do a file analysis. I’d imagine it’d HAVE to modify Greagoir’s dialogue, at least, and I make a lot of important changes to that one.

    Damage Statistics Fix: Didn’t do this one, considering it in the category of “Combat fixes”. That said, if I do decide to do a combat fixpack, I’ll include it in that.

    Clothed Prisoners: Not a bug, more of an addon to Natural Bodies. Probably compatible.

    Paragon Weapon Rune Fix: Correct me if I’m wrong, but I believe this is for Awakening only. No conflict if so.

    Ostagar Mage Chest Key: I don’t do this. I do add a closing journal entry if you get to Flemeth’s Hut after the Battle with the key indicating you might still find a use for it (in the vanilla game the quest just gets stuck open forever, so I consider that a fix). IMO, the chest in Return to Ostagar is intended as a reward for players who role-playingly chose to NOT steal from their own side, and I don’t feel a need to interfere with that intent.

    Statistics Fix Bosses Killed: See Damage Statistics Fix above.

    Do I plan to do my own version of combat fixes? I didn’t plan on it, because I thought that had been covered well by existing mods, but the more I hear about them, the more I’m realizing that every one of them out there seems to have issues of one sort or another. I am now considering it. No promises though.”

    #486
    Mckatsims
    mckatsims
    Participant

    Toggling vertical sync off actually turns my loading screens into a graphics nightmarish mess, so it’s best that I keep it on. I’m not sure if the no helmet hack uses Event Manager, I’m not seeing anything on the mod’s page that mentions it, but I know I use a few mods that do (e.g., a mod replacing spiders with the deepstalker body).

    I’ve continued pulling out texture-centric mods, and for whatever reason, Dracomie’s True Textures seems to be a culprit. It seems to be less about an incompatibility with your fixpack, and more an issue with script heavy Denerim. Plus, since upgrading to Windows 10, I’ve had more graphic glitches and issues in general, which means I probably need to do a clean install (which I’m dreading) to get rid of them.

    Taking out the True Textures mod seems to have fixed the issue, for the most part. I’m almost finished with this runthrough – just have the Alienage, Landsmeet, and the final battle to complete.

    #507
    Qwinn
    Qwinn
    Keymaster

    Copied questions from the Nexus forums. responding to MEsk90:

    Finally figured out how to open the forum. It does open on my phone but still can’t figure how to register with iPhone.

    Still don’t know why you can’t open it in any browser, strange. I don’t have an iPhone but on my Android, the sidebar (which is where the login and register options are) gets moved to the bottom, after all the left-side content. So scroll waaaay down and you should see those options. Tested Register on my phone and seems to work fine.

    Dead Templar and Fade Qunari Fix -4003
    are you sure about this?

    Yes. Someone wearing Templar armor labeled “soldier” is not a definitive bug, IMO. Non-Templars can wear Templar armor, and all Templars are also soldiers. IMO, if there is a bug, it’s that those guys have Templar armor at all, it should probably be generic armor – why are Templars in the Brecilian Forest anyway? But as there’s no way to know, I’m leaving it alone.

    have you saw this one too? A Fallen Templar Quest Fix -3858

    *twitch* Um, yeah, I’ve seen that one. *twitch* Please see RD3104 in the “Redacted From Previous Versions” for details. *twitch*

    Nukenin’s Stealing Fix -BIO2383
    it doesn’t count as combat mod does it?

    Yes, as far as the kind of mods that it would conflict with.

    A fix for Morrigan’s kiss -4556

    This doesn’t rise to the level of bug for me. It’s not like Morrigan had a normal upbringing. If she sometimes kisses with her eyes open, it does seem oddly consistent with her character to me. And if I were to do it, it could conflict with tweak mods that make much more extensive changes to those kiss scenes. So, leaving it alone.

    Party Friendship Soundset -4492

    Completely redundant – this is handled by fix GL3002. That said, if you use other mods that overwrite player_core.nss/ncs, as many combat/game mechanics mods do, that mod will overwrite my fix to this issue. The v3.3 readme will explain this in more detail.

    Ghost Elves -4434

    I do agree this is a fix, but it’s also a morph mod, and I don’t want to make a lie out of my statement that my mod has *no* conflicts with morph mods. I will add it as a “Recommended Mod” with that explanation in my v3.3 Readme.

    I’ve seen the post that you state the same thing for Alistair’s Oath as well. If you finally decide to include other file type please put these in your priority list. These two mods are the first ones I expected to be in your fix pack.

    While I understand the reasoning for it, I don’t think Alistair’s Oath ranks as a fix. Perhaps Alistair values his amulet too much to risk breaking it in combat, and he keeps it tucked away inaccessible to the player. He also already comes with an item restricted to him (Runic Worry Ring). As stated previously, if you disagree and think it IS a fix, you can always install that mod, it should be compatible.

    Boob Patches -3962
    Pretty much a tweak but vanilla looks hideous IMO

    Should be compatible. Obviously doesn’t belong in a Fixpack.

    Redcliff Revival -3957
    Just this phrase in description “A fair Chance”

    It is possible to do it in Nightmare – did it myself 7 years ago. Think it took me half a night. Is it one of the harder challenges in the game? Absolutely (which is why I scale the reward for accomplishing it so it’s not utterly insulting/ludicrous/fourth wall breaking). Does that make the difficulty a bug? IMO, no. You know what was an insanely difficult challenge AND a bug? Having to fight both Bhelen and Harrowmont fanatics in Orzammar at the same time. Surviving that is arguably harder than saving everyone in the Siege. Thankfully, that WAS a bug, and you won’t have to deal with it in my Fixpack.

    Visible Commands -1110
    Pretty much a tweak

    Actually, the description of the mod suggests it’s a fix. I’ll look more into it.

    Unlimited Stacks -648
    Tweak, No?

    Yes.

    About Compatibility:

    Dark Promise 1.02 -1611

    Unfortunately not compatible, sorry. I do make changes to the area file of the second floor of post-Landsmeet Redcliffe castle, for the restoration of Loghain and Anora’s dialogue. IF that mod ALSO overwrites the area script, then it may possibly work (overriding both my files), but you will also lose some of my fixes such as some plot item removal and Morrigan not appearing until after you’ve talked with Riordan (which was definitely a bug).

    Thanks for the list!

    #616
    Portucally
    Portucally
    Participant

    I’m starting a new playthrough, this time with a male human noble, so that some bugs/incompatilibies I noticed with my male dalish might be removed…
    Anyway, is there a compatiliby issue with Farewell Ser Gilmore by Kajana or the Noble Couslands of Ferelden – Origins by TommyIrianto?

    Those are the only mods I’m using that might cause the dialog at the gate with Ser Gilmore to hear him saying one thing and the subtitles showing another. And also cut his speech mid-sentence and replace with another…

    I’m thinking maybe Farewell Ser Gilmore as Couslands of Ferelden are basically visual/graphics.
    I’ll try again without the Ser Gilmore mod to be sure…

Viewing 15 posts - 1 through 15 (of 49 total)

You must be logged in to reply to this topic.